Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to fake xinput events with xte:

xte "str $(echo '<ABC@gmail.com>')"

But, I get:

WQBC@g;qil<co;X

That's really weird, I'm using US keyboard and mapping, but xte gives this very different result.

UPDATE

Output from xte "str '<ABC@gmail.com>'"

4WQBC@g;qil<co;X4

share|improve this question
    
Does xte "str '<ABC@gmail.com>'" work? (This is probably not what you want (in the end), but for debugging...) –  sr_ May 25 '12 at 9:09
    
@sr_ rather wired –  warl0ck May 25 '12 at 9:21
    
@sr_ , i configured both french and english keyboard in xorg.conf , but since my current output has no problems , it shouldn't happen with xtr either –  warl0ck May 25 '12 at 9:21
    
Hmm. Both outputs differ in the quotation marks only ('=4, apparently)... –  sr_ May 25 '12 at 9:25
    
This discussion is enlightening (not sure if the patch helps, though) but apparently upstream fixed that issue –  sr_ May 25 '12 at 9:28

1 Answer 1

As an alternative you can try:

xdotool type  --clearmodifiers -delay 0 "string to type at fake input"

I found it works a lot better than xte version 1.02 which seemed to have a 255 character limit. Or xte version 1.0.7 which seemed to ignore all newlines in the string.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.