Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to access www.belgacom.be using Firefox from my Archlinux system and I get the following error:

Firefox can't find the server at www.belgacom.be

When I use Chromium, it works perfectly.

I tried deleting the ~/.mozilla directory, with no success. I've also tried running Firefox from another user session, with no luck.

I'm running the latest version of Firefox.

Any ideas?

share|improve this question
    
What abourt other websites, do these work? –  jippie May 21 '12 at 18:25
    
Yes all other websites are working –  Ben D May 21 '12 at 18:40
    
What does host www.belgacom.be return from your machine? Does Chromium have a proxy configured? –  EightBitTony May 21 '12 at 21:56
1  
What are your proxy settings in Chrome and Firefox? What is your DNS configuration (if you don't know, start by posting the content of /etc/resolv.conf)? –  Gilles May 21 '12 at 23:11
    
host www.belgacom.be www.belgacom.be has address 195.13.15.25 Host www.belgacom.be not found: 3(NXDOMAIN) –  Ben D May 22 '12 at 9:36
show 3 more comments

2 Answers

I have the same problem on a fresh Archlinux installation.

My resolv.conf contains only

nameserver 192.168.1.1

(plus a few comments) It's the address of my "box" (router, modem...). It works perfectly for every other domain (Belgacom is my ISP).

I tried a ping but it fails. I installed Chromium to test and it's working but it's not working with Epiphany, so I guess it's not a problem with Firefox. Other computers (on Ubuntu) using the same address as nameserver can access to this domain.

A dig gives me this result :

; <<>> DiG 9.9.1-P1 <<>> belgacom.be
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17483
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4000
;; QUESTION SECTION:
;belgacom.be.           IN  A

;; ANSWER SECTION:
belgacom.be.        1643    IN  A   195.13.15.25

;; Query time: 67 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Mon Jul 23 02:57:59 2012
;; MSG SIZE  rcvd: 56

I fixed this problem by adding 2 old dns servers to /etc/resolv.conf :

nameserver 195.238.2.21
nameserver 195.238.2.22
share|improve this answer
add comment

If it works on the same machine under a different browser check if you have proxies enabled or if any of the installed addons is interfering with DNS resolution.

Since you already removed your profile folder and even tried different user sessions, my bet goes to preinstalled addons or proxies.

Close any firefox instance and try firefox -safe-mode. If this doesn't work, check that you don't have any proxy enabled.

If neither works, I've no idea what could be wrong.

share|improve this answer
    
I tried running firefox in safe mode with no success. I don't have any proxy –  Ben D May 21 '12 at 17:29
    
Just out of curiosity, that address wouldn't happen to be the place where you work? I'm wondering if you have something on your /etc/hosts file or in the network that makes the address resolve locally instead of via the external address... –  Unode May 21 '12 at 19:43
    
No, I'm trying to access it from home. –  Ben D May 22 '12 at 9:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.