Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I installed DivFix++ from

http://sourceforge.net/projects/divfixpp/files/DivFix%2B%2B/v0.34/

DivFix++-0.34-2.1.x86_64.rpm

$ env LC_MESSAGES=C DivFix++
Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6).
Abgebrochen
$ uname -a
Linux a 2.6.32-220.13.1.el6.x86_64 #1 SMP Tue Apr 17 15:16:22 CDT 2012 x86_64 x86_64 x86_64 GNU/Linux
$ rpm -qa | grep -i divfix
DivFix++-0.34-2.1.x86_64
$ 

Question: how can I get DivFix++ to work under Scientific-Linux 6.1?

UPDATE#1 (I tried to install from source)

[USERNAME@MACHINE ~/Desktop/D/DivFix++_v0.34] ls
contrib  debian  DivFix++.cbp  DivFix++.fbp  docs  locale  makefile  resources  src  wx_pch.h
[USERNAME@MACHINE ~/Desktop/D/DivFix++_v0.34] make
`wx-config --cxx` `wx-config --cxxflags` -c src/DivFix++App.cpp -o src/DivFix++App.o
`wx-config --cxx` `wx-config --cxxflags` -c src/DivFix++.cpp -o src/DivFix++.o
`wx-config --cxx` `wx-config --cxxflags` -c src/DivFix++Core.cpp -o src/DivFix++Core.o
`wx-config --cxx` `wx-config --cxxflags` -c src/DivFix++Gui.cpp -o src/DivFix++Gui.o
`wx-config --cxx` src/DivFix++App.o src/DivFix++.o src/DivFix++Core.o src/DivFix++Gui.o `wx-config --libs` -o DivFix++
[USERNAME@MACHINE ~/Desktop/D/DivFix++_v0.34] DivFix++
Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6).
Abgebrochen
[USERNAME@MACHINE ~/Desktop/D/DivFix++_v0.34] 

Searching for wxwidgets:

[USERNAME@MACHINE ~]# rpm -qa | grep -i wx
wxGTK-2.8.12-1.el6.rf.x86_64
wxGTK-devel-2.8.12-1.el6.rf.x86_64
[USERNAME@MACHINE ~]# 
share|improve this question
add comment

2 Answers 2

Looks like this RPM was built for another distro. You can compile the program from source, which should solve this problem.

share|improve this answer
    
how to compile? –  gasko peter May 20 '12 at 20:54
1  
Download the source tarball, decompress it and run make inside the new directory. You will need the wxWidgets development libraries (search on yum). –  Renan May 20 '12 at 20:56
    
I edited my question with UPDATE#1 –  gasko peter Jun 2 '12 at 14:29
    
How to install wxWidgets on Scientific-Linux 6? –  gasko peter Jun 2 '12 at 14:32
add comment
up vote 1 down vote accepted

installed through wine, works :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.