Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I already have the VM (Xen based) installed, but the Xen config used specified "Linux kernel" as "None".

The exact command line was:

ubuntu-vm-builder xen precise -v --debug --addpkg openssh-server

Two images and a xen VM config was generated in /etc/xen/ubuntu-xen , I'll provide more info later , i'm at the other computer now.

How should I start the VM?

UPDATE

I got a xen.conf :

# Configuration file for the Xen instance ubuntu, created
# by VMBuilder
kernel = 'None'
ramdisk = 'None'
memory = 128

root = '/dev/xvda1 ro'
disk = [
'tap:aio:/root/ubuntu-xen/tmpZV_BzU,xvda1,w',
'tap:aio:/root/ubuntu-xen/tmpeUm7XN,xvda2,w'
]

name = 'ubuntu'

dhcp    = 'dhcp'
vif = ['']

on_poweroff = 'destroy'
on_reboot   = 'restart'
on_crash    = 'restart'

extra = 'xencons=tty console=tty1 console=hvc0'
share|improve this question
    
What artifacts did vmbuilder create? What options did you pass it? Did it create a script, config file, image, etc.? The more information you can provide, the more we can help. –  Todd Deshane May 19 '12 at 22:48
    
@ToddDeshane , i got a ext3 loop image and a xen.conf , the image was not empty. –  warl0ck May 23 '12 at 1:29

2 Answers 2

up vote 0 down vote accepted

You should be able to start the VM with:

xm create /path/to/xen.conf

Alternatively, you can decide to use other toolstacks on Ubuntu based on your needs (see https://help.ubuntu.com/community/XenProposed)

share|improve this answer
    
I get the following error: Error: Cannot find kernel "None". Any ideas? –  user1202136 May 2 '13 at 9:30

I would recommend to create the PV guest with the installer as described on: https://help.ubuntu.com/community/XenProposed

Alternatively, you should be able to use the image that vmbuilder created.

More info needed. (I'll post a comment and we can edit this when we figure this out)

share|improve this answer
    
I provided the xen.conf generated , not sure why kernel should be 'None' here –  warl0ck May 25 '12 at 8:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.