Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I recently installed ubuntu 10.10. Graphics were actually fine, by just using the default drivers, and I could drag windows fast and smoothly.

However, since I have an ATI Radeon HD4870 card I should be able to get more out of it by installing the ATI driver for linux. So, I decided to install the ATI drivers for my radeon 4870.

Now my resolution is fine and everything looks alright, but when I drag windows its not smooth at all and very laggy.

I haven't seen any other implications, although I didn't test any graphic heavy applications. The window dragging is very laggy though and thus a problem.

Any idea what could cause this?

share|improve this question
add comment

4 Answers

If dragging windows is laggy (scrolling is probably fine), it usually means you're on software rendering and you didn't install those drivers properly.

share|improve this answer
    
I would go with this. You probably didn't install the driver correctly or you installed the wrong driver. –  Falmarri Nov 11 '10 at 0:14
add comment

It could be that you already had the fglrx (ATI proprietary) driver installed, and what you just installed is the open source driver. The open source driver is generally slower than the proprietary driver.

It could also be the reverse - if the open-source driver was compiled with DRI (direct rendering infrastructure) support but the fglrx driver was not, it can be slower.

share|improve this answer
add comment

Desktop seems to get smoother adding in /etc/X11/xorg.conf, under the device section the following options:

Option "AccelMethod" "EXA"
Option "MigrationHeuristic" "greedy"

Source.

share|improve this answer
add comment

If possibly your window manager (Compiz, possibly?) or window decorator (possibly Emerald) is using a fancy effect like alpha blur, that might cause this problem.

share|improve this answer
    
The thing is that everything worked fine before I installed this driver. –  Tom Nov 10 '10 at 11:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.