Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I installed CentOS 6.2 about a month ago and it worked fine. Two days ago I saw that the internet connection is broken, so I reconfigured it. I was able to use it but after a few minutes it broke again. I realize the network configuration is reset every 5 minutes. How can I repair it?

I use Static IP.

share|improve this question
2  
There is a big regression in the RHEL kernel for some intel cards. To the date, there are only several temporary workarounds available. Do you have intel card? What kernel says? –  lzap May 18 '12 at 7:56
1  
Can you edit your question and add some more information? How are you configuring your network connection, static IP or DHCP? Are you manually editing the configuration files? Is this a wireless or wired network connection? –  uther May 18 '12 at 12:07
    
Landline ? or wireless, please let us know –  warl0ck Jul 18 '12 at 8:55
add comment

1 Answer

My co-worker installed ubuntu and had his network connection break similar to the way you described it. He traced the problem to using wireless n (his network connection was over a wireless USB card that used an Atheros chipset). Once he turned the wireless router to mixed (instead of using wireless n exclusively) this problem went away.

YMMV.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.