Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My wireless worked when I first installed. I needed to turn it off for a while, so I clicked "off" in the pulldown dialog. I used the wired network for awhile, but when I went to turn my wireless back on, it started connecting for half a second then dropping the connection. I can use the wired interface but my office doesnt have a wire so I have to go out into a common room to work. Very irritating. Can anyone help me? Note that this isn't the same problem as this, as he never had wireless afaict. Maybe it is and I don't understand something.

UPDATE: The device is a Atheros AR5B91, and dmesg is reporting the following:

[  314.769728] wlan0: authenticate with 00:22:3f:80:10:fc
[  314.787528] wlan0: send auth to 00:22:3f:80:10:fc (try 1/3)
[  314.789526] wlan0: authenticated
[  314.804098] wlan0: associate with 00:22:3f:80:10:fc (try 1/3)
[  314.806466] wlan0: RX AssocResp from 00:22:3f:80:10:fc (capab=0x421 status=0 aid=3)
[  314.806470] wlan0: associated
[  316.024238] wlan0: deauthenticating from 00:22:3f:80:10:fc by local choice (reason=3)
share|improve this question
What is the wireless card? Does it work if you run from a live-CD? – Renan May 17 '12 at 18:38
@Renan Thanks for the comment. Yes, it worked off of the live-CD. It also worked after a new install. I'm trying to determine the exact wireless chipset now. – Nathan C. Tresch May 17 '12 at 18:55
@Renan I've updated my question with more information. – Nathan C. Tresch May 17 '12 at 19:17
This hasn't been a problem since switching to Mint 13. – Nathan C. Tresch Nov 24 '12 at 1:02

Somewhere there is a security setting that I have tripped, I suspect. What fixed the problem was enabling security on the router. Prior to this, I have been using an access list of MAC addresses with an open wifi router. I'm not sure what changed, but, I somehow turned security of some kind on is my hypothesis.

If I get time I'll research what changed and report here.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.