Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

An application with a Russian UI shows question marks instead the most of its text (some elements are rendered ok though).

The system locale is English (en_US, en_IE), I've tried Ubuntu ant XUbuntu 12.04 with Wine 1.5.

I've tried launching the application with

LANG=ru_RU.utf8 wine myapp.exe

but it doesn't help.

I have also checked that ttf-mscorefonts-installer is installed.

If I use Windows, setting Russian codepage for non-unicode apps in the Control Panel solves the problem.

Any ideas?

share|improve this question

3 Answers 3

Unix locale has no meaning for programs running in WINE. You should configure winodws-in-wine for Russian.

share|improve this answer
    
This answer used to help in the past: unix.stackexchange.com/a/2707/2119 - that's why I've tried LANG this time. If you think this is not the way, then what would you recommend? –  Ivan May 19 '12 at 17:46
    
First, export LANG=ru_RU.utf8 appname is wrong expression, you should omit export and use LANG=ru_RU.utf appname. Second, run Windows Control Panel in WINE and set Cyrillic. –  paul May 22 '12 at 11:53
1  
how do you mean to run Windows Control Panel in WINE? If you mean "wine control.exe" - it results in this: imgur.com/31BfO - no codepage settings applet there. If you mean "wine control.exe intl.cpl" - it just does nothing (I've tried Wine's control.exe and original Windows control.exe with Wine's default and original Windows intl.cpl). –  Ivan May 23 '12 at 0:30

I managed to do this on FreeBSD and Wine 1.5.24 by setting LC_ALL and LANG to ru_RU.UTF-8. Note that it is ru_RU.UTF-8 and not ru_RU.utf8, with the later being an invalid locale name on my system, at least. I guess that this can be the problem on other *NIX systems, and in your specific case, too.

HTH

share|improve this answer

Firstly, LANG might not suffice. Use LC_CTYPE. Then, if your system locale is not Russian, it's likely that you haven't installed this locale. To install it, do the following as root (these examples are for Ubuntu, adapt them to your distro):

echo ru_RU.UTF-8 UTF-8 >> /var/lib/locales/supported.d/local
dpkg-reconfigure locales

After this running e.g. LANG=ru_RU.utf8 cal should give you Russian calendar for current month. If this doesn't, try

locale-gen --purge --no-archive

Now you should be able to run your wine app as

LC_CTYPE=ru_RU.utf8 wine myapp.exe
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.