Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I installed monodevelop from the repositories because I want to try the mono-D plugin, but when I go to the Gallery in Add-in Manager, it says "No add-ins found"

I tried adding http://mono-d.alexanderbothe.com/ as a repository, but it requires monodevelop version 2.95 and the one in the repository is version 2.6:

The selected add-ins can't be installed because there are dependency conflicts

The package 'Ide v2.9.5' could not be found in any repository

share|improve this question

1 Answer 1

up vote 3 down vote accepted

It looks like monodevelop 2.95 is a development release, so won't find it in the repository. Monodevelop 3.0 has just been released (May 14, 2012). I think this is the version you need. You can download it from MonoDevelop web page. No prebuilt package is available for Ubuntu/Mint right now, so you best option is to build it from the source (using the previous version of mono presumably). If you are new to building packages from source, it is actually a straightforward process (once you have all the build tools/libraries installed):

  • download
  • untar
  • ./configure
  • make
  • sudo make install

Alternatively you can wait for a prebuilt package.

share|improve this answer
    
I ran ./configure --prefix=pkg-config --variable=prefix mono (like it says in the README file) and it failed with config.status: error: cannot find input file: `src/addins/MonoDevelop.CodeMetrics/Makefile.in' –  dspyz May 15 '12 at 22:32
    
Tried to build myself, had the same problem and indeed src/addins/MonoDevelop.CodeMetrics/Makefile.in is missing. However, I managed to configure the git version. You might try that one. –  Levon Haykazyan May 15 '12 at 23:06
    
Hahah, it worked. Thank you. This was definitely more effort than I anticipated –  dspyz May 15 '12 at 23:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.