Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Ubuntu is able to detect my Lenovo "Mic Mute" button with acpi_listen, but when I try it on Arch Linux, there is no output available.

Model: Thinkpad X220 4290LY9

Tried to add acpi_osi=Linux in kernel cmdline, but mic mute still has no output from acpi_listen.

After adding acpi_osi option, the led of my output mute button, no longer toggles, but it still functions.

share|improve this question
Apart from comparing their dmesg output, adding acpi_osi="Linux" to the Kernel command line could help (Does it?) – sr_ May 15 '12 at 13:27
@sr_ tried , no luck – warl0ck May 15 '12 at 13:36
See if xev can detect it. You can use amixer to mute, though that might not be what you want. – user13742 May 15 '12 at 14:08
@hesse , no either – warl0ck May 15 '12 at 14:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.