Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I maintain a local repository for all the installation packages. I'm attempting to use reposync (the first time, I generally use rsync to mirror what I need) and I'm getting some odd behavior. Any repos I have enabled system wide at /etc/yum.repos.d/MYREPO.conf are being pulled in to the list of directories to sync.

./reposync -n -c vmware-tools.cfg -p tmp -u

I really don't want to provide a list of repos to include - I'd like to simply add the necessary lines to the above file and have it work.

The contents of vmware-tools.cfg.

[6-i386]
name=VMware Tools 6 x32
baseurl=http://packages.vmware.com/tools/esx/latest/rhel6/i386
enabled=1
gpgcheck=1

[6-x86_64]
name=VMware Tools 6 x64
baseurl=http://packages.vmware.com/tools/esx/latest/rhel6/x86_64
enabled=1
gpgcheck=1

[5-i386]
name=VMware Tools 5 x32
baseurl=http://packages.vmware.com/tools/esx/latest/rhel5/i386
enabled=1
gpgcheck=1

[5-x86_64]
name=VMware Tools 5 x64
baseurl=http://packages.vmware.com/tools/esx/latest/rhel5/x86_64
enabled=1
gpgcheck=1

How do I correct this behavior and / or sync these files in a better fashion?

share|improve this question
    
So reposync is downloading everything in /etc/yum.repos.d/ instead of just what's in vmware-tools.cfg? –  mgorven May 13 '12 at 5:04
    
@mgorven- yes, that is it exactly. –  Tim Brigham May 13 '12 at 22:50

1 Answer 1

From the reposync help:

 -r REPOID, --repoid=REPOID
                    specify repo ids to query, can be specified multiple
                    times (default is all enabled)

That means you will need to pass the -r option to reposync and the name of the repo to sync. So, your command should look like the following:

./reposync -n -c vmware-tools.cfg -p tmp -r 6-x86_64 -u
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.