Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm on the latest Linux Mint release on an Acer Aspire S3. Unfortunately I can't set the screen brightness in the Screen preferences. It doesn't matter which position the slider has, it's always the same brightness. Am I doing something wrong? Is there another way to set the brightness?

share|improve this question
this still happens with Linux Mint 13 (Maya) –  Michael Kohler May 23 '12 at 21:28
Still happening with Mint 16. :( –  GreenMatt Oct 6 at 2:00

7 Answers 7

up vote 3 down vote accepted

I have a similar problem with my screen and found this solution, hope it helps you


share|improve this answer
This works perfectly! Now I can set the brightness with my FN keys. –  Michael Kohler Sep 11 '12 at 16:59
Please add the relevant information from that link to your post. As it is, when that link goes bad (it's not working right now), your answer is useless to people at large. –  Mat Sep 22 '12 at 15:40

I am looking at fixing this in my LMDE 13 and came across this How do I set default brightness after boot?.

It has fixed it for many, however in my case, I am not able to find a directory in /sys/class/backlight. Perhaps that means a proper driver is not loaded.

share|improve this answer
Thanks for your reply. That would be a workaround, but I actually also need to be able to adjust the brightness using the FN key and not just telling it how bright the screen should be. When I'm on battery I don't want it to be max brightness, on AC I do. –  Michael Kohler Sep 11 '12 at 16:19

The solution from @RoQ is working fine. Here are the steps :

  • Edit the /etc/default/grub file with superuser privilege
  • Change GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
  • Update the grub with the following command : sudo update-grub and reboot your computer

That's it

share|improve this answer

I added acpi_osi= to grub and this helped my Acer 5742z with intel graphics, hope this helps you.

share|improve this answer

For mint mate 17, you can set the default brightness by following steps:

  • sudo apt-get install dconf-tools
  • Applications -> System Tools -> dconf tools,
  • search for backlight, find and change following options:
    • brightness-ac: brightness when use AC powser (charged),
    • brightness-dim-battery: brightness when use battery (not charged),
share|improve this answer

For all of you running a Laptop with NVIDIA Card and who are still not able to get the f* function keys for brightness to work, just follow the steps below. It worked very well for my system (Samsung q45, Intel Dualcore T7100 @ 1,8Ghz , Nvidia Geforce 8400M G 512) running Linux Mint 17.

In command line, type in:

sudo gedit /etc/X11/xorg.conf

You will have to enter your root password.

Now, you should see:

Section "Device" Identifier "Device0" Driver "nvidia" VendorName "NVIDIA Corporation" EndSection

If you see nothing, just enter all the lines above and follow up with the next step below

Under the VendorName Line, add the following:

Option "RegistryDwords" "EnableBrightnessControl=1"

Now, save and reboot. Check your brightness controls, and hopefully this fixed things.

I've tried so many solutions out of the net and nothing had helped me until I came to this solution. But be aware that these steps only working for NVIDIA Grafics and you must have chosen the NVIDIA Driver in your system in "Administration -> Driver Manager".

share|improve this answer

Changing the grub command line is the right way to do it, but the problem is that acpi_backlight=vendor is wrong. The correct one is: acpi_osi=Linux

It still always worked for me on a lot of laptops.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.