Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I need to run xrestop on a remote machine. When I connect through ssh and run xrestop I get the results for my local machine.

I see that there is an option -display but I don't know how to use it.

How to run xrestop remotely ?

share|improve this question
    
Maybe it's because of X11Forwarding. Can you try with ForwardX11 set to No in ~/.ssh/config ? –  Coren May 9 '12 at 12:38
1  
add comment

1 Answer

up vote 3 down vote accepted

You use the -display option as normal. The standard display is :0. So if you're logged in via ssh you can run:

xrestop -display :0

Generally you can also explicitly set your DISPLAY shell variable to :0 and all X programs will interact with the remote machines primary display.

share|improve this answer
    
Thank you this is exactly what I wanted. I had tried with "-display :0.0" without success. –  Barth May 9 '12 at 12:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.