Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm experiencing some DNS issues on a new RHEL 6 virtual machine. Ping is working fine to an IP, but the machine is unable to resolve any names. I've tried adding Google's DNS servers ( and to the bottom of /etc/resolv.conf but it's not having any affect. Even manually adding items to my /etc/hosts file doesn't seem to work. Does something need to be reset? Anything else I can try?

This is the contents of my /etc/hosts file:      localhost localhost.localdomain localhost4 localhost4.localdomain4
::1            localhost localhost.localdomain localhost6 localhost6.localdomain6 download.fedoraproject.org   google.com

However I still can't nslookup or ping to google.com.

EDIT: Solved. Was a firewall issue blocking the DNS requests.

share|improve this question
As you solved it, you should answer your own question and marked it as the correct answer. See How to handle self-solved problems – Huygens May 9 '12 at 8:26

I know this issue has been solved, but in case someone stumbles across this trying to solve a similar issue, it might help to check /etc/nsswitch.conf to make sure the hosts line contains files when adding manual entries to /etc/hosts doesn't fix it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.