Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm on a new Linux (installed yesterday). When I access files from old partitions their file names have incorrect encoding (ä instead of ä, same for other umlauts) inside KDE apps like dolphin and konsole.

All characters look correct when I display them in tty and GTK apps. (And they obviously also did so on the old system.)

How can I make KDE4 show the file names correctly?

share|improve this question
    
You probably needed LANG=*.UTF-8 in the environment such as export LANG=en_US.UTF-8. Now can you tell me why StackExchange is giving me a four year old question (which I just noticed). – msw Feb 3 at 0:32

You need to figure out the file encoding of the partitions in question, and set that encoding in fstab for the partition. I am assuming that the partitions in question are NTFS or FAT from a Windows setup. What language was Windows in? German?

share|improve this answer
up vote 0 down vote accepted

(Moved answer from May 2012 from question to here)

So now I «fixed» this by re-installing the system. No idea what the problem was.

To get the keyboard right everywhere (tty, KDM login screen, KDE) I had to run

dpkg-reconfigure locales       # Kept only (de_CH|en_US|ru_RU).UTF-8
                               # Selected de_CH.UTF-8 as default
dpkg-reconfigure console-data  # Selected German (Switzerland) 
dpkg-reconfigure keyboard-configuration 
                               # Selected my 105-key Cherry CyMotion Xpert 
                               # AltGr on right Alt, no Compose key

Running keyboard-configuration first does not work since those settings are specific to the default keyboard selected in locales; for en_* e.g. there is no AltGr and no compose key.

(Debian based system.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.