Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

acpi-cpufreq was already loaded , where the frequency was all 800MHz now , and I can't make it back to full-speed , which is 2500MHz.

I tried cpufreq-set -g performance , then I check /proc/cpuinfo , it was still 800MHz

Is there anything wrong ?

UPDATE

It's a i5 CPU , part of cpu information provided below:

processor   : 3
vendor_id   : GenuineIntel
cpu family  : 6
model       : 42
model name  : Intel(R) Core(TM) i5-2450M CPU @ 2.50GHz
stepping    : 7
microcode   : 0x25
cpu MHz     : 800.000
cache size  : 3072 KB
physical id : 0
siblings    : 4
core id     : 1
cpu cores   : 2
apicid      : 3
initial apicid  : 3
fpu     : yes
fpu_exception   : yes
cpuid level : 13
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips    : 4986.76
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:
share|improve this question
    
is that an uniprocessor system? –  Dmitri Chubarov May 6 '12 at 4:25
    
@DmitriChubarov updated –  warl0ck May 6 '12 at 4:31
    
cpufreq-set -g affects only the first cpu on a multicore system. Try for i in `seq 0 3` ; do cpufreq-set -c $i -g performance; done –  Dmitri Chubarov May 6 '12 at 4:46
    
@DmitriChubarov no lock , still all 800MHz ... –  warl0ck May 6 '12 at 5:59
    
@DmitriChubarov solved , check my answer –  warl0ck May 11 '12 at 9:10
add comment

1 Answer

up vote 2 down vote accepted

Alright , this was said to be a bug with Thinkpad ,

When your battery is unplugged , and connected to AC power higher than 65W , the freq will stuck at lowest , check the /sys/devices/system/cpu/cpuX/cpufreq/bios_limit , to see if it's stuck.

Source: http://www.thinkwiki.org/wiki/Problem_with_CPU_frequency_scaling

I got it solved by passing kernel parameter: processor.ignore_ppc=1

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.