Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a specific MP4 video file that plays fine in MPlayer and VLC, but other programs on my Arch Linux box (Banshee, Gnome's Movie Player) are unable to play it. Most seem to treat it as having zero length. It also causes Gnome's Properties dialog to just display a dialog saying "Creating Properties Window" and never load.

What is it about this file that causes it to do this?

share|improve this question
    
We'd have to see the file, and even then this is probably simply a bug in xine/gstreamer –  xenoterracide Nov 5 '10 at 23:32
1  
Or a misencoded file that mplayer and vlc happen to be able to handle –  Michael Mrozek Nov 6 '10 at 4:55
    
Can't upload the file, given that it's a full movie, sorry. –  Macha Nov 8 '10 at 19:28
add comment

2 Answers 2

up vote 0 down vote accepted

This appears to be because of a misencoded file. Encoding with a different application than originally used did not have the same result.

share|improve this answer
add comment

You've installed the needed gstreamer plugins?
(don't know exactly which, maybe gstreamer0.10-bad or gstreamer0.10-ffmpeg) ...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.