Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The resolution of the TTY1-6 is poor ~ 640×480

Ubuntu 11.10 | Grub2 | nVidia | NVIDIA GT215 Board

I went through the process on this site and after the edit the GRUB menu appears in the correct (more refined resolution). But after it boots into GNOME (via gdm3) and I attempt to view terminal 1-6 the screen is barely or completely unreadable.

I am able to revert my changes but I am looking to restore the fine resolution the terminal screens are capable of.

To determine the screen resolutions avail. to me, I used:

hwinfo --framebuffer | grep "Mode"
Mode 0x0369: 1680x1050 (+6720), 24 bits

These are the steps I went through. edit 1) grub config 2) initramfs modules, then 3) update

sudo vi  /etc/default/grub

Find the fol­low­ing three lines.


Change them to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1680x1050-24,mtrr=3,scroll=ywrap"


sudo vi  /etc/initramfs-tools/modules

Adding/editing line:

uvesafb mode_option=1680x1050-24 mtrr=3 scroll=ywrap

Cre­ate a new file:

echo FRAMEBUFFER=y |  sudo tee /etc/initramfs-tools/conf.d/splash

Finally update the configuration files:

sudo update-grub2
sudo update-initramfs -u

Again, the GRUB menu in the beginning of the boot-up process shows the more refined resolution (including small font size), but small refined focused resolution disappears for terminals after boot up.

share|improve this question
In earlier versions (Maverick), I forced the TTY resolution with this in /etc/default/grub: GRUB_GFXPAYLOAD_LINUX=1680x1050. Also, if you are using uvesafb have you installed v86d? – jasonwryan May 5 '12 at 21:49
v86d installed and the latest version (according to apt-get), the interesting thing is that the grub resolution appears as 1680x1050 but as soon as the boot up process begins the resolution returns to (a lousy) 640×480. – DanCat May 5 '12 at 22:16
This was my /etc/default/grub from Maverick: codepad.org/vkufRCcb – jasonwryan May 5 '12 at 22:38
Are you also using the edits in uvesafb? – DanCat May 6 '12 at 1:45
thank you, your suggestion worked. – DanCat May 14 '12 at 5:29

Add the following after your GRUB_GFXMODE line in /etc/default/grub:

share|improve this answer

I had a similar issue. Installed the nvidia graphics drivers on Debian and suddenly the TTY resolution went awry. I was not particularly worried about the resolution of GRUB itself though, only the console I would get from it.

With such simplifications of the problem the following portion from the OP worked perfectly for me:

sudo vi /etc/initramfs-tools/modules

Adding/editing line:

uvesafb mode_option=1680x1050-24 mtrr=3 scroll=ywrap

Finally update the configuration files:

sudo update-initramfs -u

I did also try the suggestion to simply add the vga=0x0369 parameter to the kernel command line. This did not work for me with the 3.2.0 kernel though

share|improve this answer

The nvidia driver doesn't support high resolution for tty, but you can use nouveau instead of nvidia

share|improve this answer
Apparently it does for @DanCat... – jasonwryan Jun 27 '12 at 22:36
I use grub, grub2 supports buffers upper than 16M ? (0x31B) – xunien Jun 27 '12 at 22:46

Do you really need to have a high resolution in the GRUB bootup screen? If not, simply add vga=0xXXXX to the kernel commandline. This works perfectly for me (running an nVidia-ION notebook with the closed-source nVidia driver).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.