Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I click my name in the upper right, then click "System Settings", then "Mouse and Touchpad", and then "Disable touchpad while typing" it affects my mouse movements. I have to wait two seconds before I can move the pointer with the touchpad.

I like the "Disable touchpad while typing" feature in general, as it prevents me from accidentally raising another window instead of the one I'm typing into, but can I have the feature only affect taps of the touchpad and not my attempts to move the mouse around?

I'm using GNOME 3.2.1 on Fedora 16

share|improve this question
    
See also Bug 673055 – Mouse freezes right after typing - bugzilla.gnome.org/show_bug.cgi?id=673055 –  Philip Durbin May 11 '12 at 23:31
add comment

2 Answers

On my ThinkPad X220T running GNOME 3 it's pretty easy to be typing along and accidentally bump the touchpad, causing some window other than the one you're typing into to be raised.

Ostensibly, the solution to this problem is to click your name in the upper right, then click "System Settings", then "Mouse and Touchpad", and then "Disable touchpad while typing" under as shown the screenshot at http://www.thinkwiki.org/wiki/Synaptics_TouchPad_driver_for_X .

This will cause syndaemon ( http://linuxcommand.org/man_pages/syndaemon1.html ) to start up with the following options:

syndaemon -i 2.0 -K -R

Here's what the options mean:

-i <idle-time>
       How many seconds  to  wait  after  the  last  key  press  before
       enabling the touchpad.  (default is 2.0s).

-k     Ignore modifier keys when monitoring keyboard activity.

-K     Like -k but also ignore Modifier+Key combos.

-R     Use  the  XRecord  extension  for  detecting  keyboard  activity
       instead of polling the keyboard state.

Having syndaemon running with those options eliminates the original problem, but it absolutely kills my productivity because the -t option is not enabled:

-t     Only disable tapping and  scrolling,  not  mouse  movements,  in
       response to keyboard activity.

Without -t, as soon as I stop typing and try to move the pointer, I can't. I have to wait 2 full seconds before the pointer will move.

Now, back at that "Mouse and Touchpad" interface, I do not see any way to configure which options are given to syndaemon and from what I can tell, the options are hard coded:

http://git.gnome.org/browse/gnome-settings-daemon/tree/plugins/mouse/gsd-mouse-manager.c?id=5ee48ce8aa66f6c4fdc4aa2c07bc03bdb83bcb65#n540

The solution is twofold. I can't abide syndaemon with its default options, so I leave "Disable touchpad while typing" unchecked. Then, to get syndaemon to start with the options I want, I run gnome-session-properties to open the "Startup Applications Preferences" dialog. From there, I click Add, fill in a name (I called mine "0pdurbin-disable-touchpad-while-typing" so it would appear at the top), and a command, which for me is the following:

syndaemon -i 1.0 -K -R -t

Again, the major change is the addition of -t so syndaemon doesn't paralyze my pointer, but while I was in there I reduced the idle time to one second.

I hope this helps someone because this was driving me crazy.

To avoid using a GUI tool like gnome-session-properties it looks like you could set up a file like this, which was created in my case:

[pdurbin@tabby ~]$ cat ~/.config/autostart/syndaemon.desktop 

[Desktop Entry]
Type=Application
Exec=syndaemon -i 1.0 -K -R -t
Hidden=false
X-GNOME-Autostart-enabled=true
Name[en_US]=0pdurbin-disable-touchpad-while-typing
Name=0pdurbin-disable-touchpad-while-typing
Comment[en_US]=
Comment=
[pdurbin@tabby ~]$ 

Incidentally, this seems to be a pretty complete list of applications that are autostarted, the ones listed in gnome-session-properties: find /etc/xdg/autostart /usr/share/autostart /usr/share/gdm/autostart/ /usr/share/gnome/autostart

share|improve this answer
add comment

Once you have created the above mentioned syndaemon.desktop file, make sure that you disable the "Disable touchpad while typing option" under Mouse and Touchpad settings before restarting the desktop.

Otherwise you will have two syndaemon processes running and the original one with 2 sec time will take preference!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.