Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have been trying to install TortoiseHG with the yum command on my RedHat system and have been struggling. I thought perhaps I should install it from the source. I used the instructions here and here. However, it still didn't work. I am afraid that I am missing something obvious. My system is:

  • RHEL 5.3
  • Mercurial 1.8.1
  • Python 2.4.3

Commands I have run to install Nautilus extension are

  • cd to a directory holding all my local repository CassieRep

    cd CassieRep

  • clone the tortoisehg repository

    hg clone http://bitbucket.org/tortoisehg/thg tortoisehg

  • create a symlink

    ln -s /home/Cassie/CassieRep/tortoisehg/thg /usr/bin

  • deal with nautilus

    mkdir -p ~/.nautilus/python-extensions
    ln -s /home/Cassie/CassieRep/tortoisehg/contrib/nautilus-thg.py \
          ~/.nautilus/python-extensions
    
  • restart nautilus

    nautilus -q

The items on my desktop disappeared. I actually logged out and log in again.I tried to type in thg on an terminal but system did not recognize it.

share|improve this question
    
What happens when you run the /home/Cassie/CassieRep/tortoisehg/thg executable on the command line? –  jsbillings May 4 '12 at 21:51
    
Also, why RHEL 5.3? You realize there are dozens of known exploits in the kernel alone? –  jsbillings May 4 '12 at 21:51
    
When I ran the command, I got the error message as ImportError: No module named PyQt4.uic.Compiler.About the RHEL version, I am not sure if I have authority to change it so I would like to deal with it first. Thanks, –  Cassie May 10 '12 at 20:26
    
I tried to check if my machine has PyQt by command yum list PyQt.It showed PyQt.x86_64 3.16-4 installed. Does it mean I have to update my PyQt ? Thanks, Or I should find a older version of Tortoise ? –  Cassie May 11 '12 at 19:05
add comment

1 Answer

This is an old thread, but I have a relevant answer in regards to CentOS 6, which might be relevant here too:

Mercurial and TortoiseHG on CentOS 6.5

I hope this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.