Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to install the octave software package on a RHEL 6 Workstation. I have installed the epel-release 6.5 package to enable the EPEL package repository. When I try to install the octave using yum, the following errors are returned:

Error: Package: 6:octave-3.4.2-2.el6.x86_64 (epel)
           Requires: libfftw3.so.3()(64bit)
Error: Package: 6:octave-3.4.2-2.el6.x86_64 (epel)
           Requires: libfftw3f.so.3()(64bit)
Error: Package: 6:octave-3.4.2-2.el6.x86_64 (epel)
           Requires: libglpk.so.0()(64bit)

I tried to use yum to search for the packages libfftw3, libfftw3f, libglpk, fftw3,fftw3f, and glpk. However, it was not able to find any of these packages. I am wondering if anybody knows

  1. Should I try to find the packages by the names fftw3,fftw3f, and glpk? Or should I search for the names libfftw3, libfftw3f, libglpk?
  2. Does this mean I have to try to find the required dependency packages online? Is there a reliable website providing these RPM packages for RHEL Workstation 6?

Thank you very much.

share|improve this question
    
Hi All, I finally just ramdonlly found those fftw and glpk packages online to install octave. So far it works and hope it will not cause any problem. –  Cassie May 3 '12 at 15:49
add comment

2 Answers

The proper solution to this problem is to add the "Optional" channel (rhel-x86_64-workstation-optional-6) to your RHN configuration for this host. It has the fftw package that provides the dependencies you need. The problem with the other answer, which is to use RepoForge, is that that repository provides duplicate packages to what is provided by EPEL and/or RHEL, and can cause yum conflicts down the road.

share|improve this answer
    
Does the 'Optional' channel require an additional entitlement? –  uther May 3 '12 at 20:09
    
@uther: No, it should not require an additional entitlement, it should be part of your workstation entitlement. –  jsbillings May 3 '12 at 20:21
add comment

yum is a flexible tool for package management. If you want to know what package provides the file libfftw3.so.3, you could query with yum like this.

yum whatprovides */libfftw3.so.3

If the package that provides the file exists in your enabled repositories, it will return information similar to this.

fftw3-3.1.1-1.el5.rf.i386 : Fast Fourier Transform library
Repo        : rpmforge
Matched from:
Filename    : /usr/lib/libfftw3.so.3

In this specific case, I believe you also need the RepoForge (formerly RPMForge) repository enabled on your system. You can enable the repository by installing the RepoForge rpm package.

sudo rpm -Uvh http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm

Now when you perform yum install octave, yum will install the package and the required dependencies automatically.

Edit: As pointed out, it's potentially risky to mix RepoForge and EPEL directories on the same system unless you really know what you are doing (enable/disable repositories, protect packages, etc). The lesson on yum functionality remains relevant.

share|improve this answer
    
It's not a good idea to mix RPMForge and EPEL. –  jsbillings May 3 '12 at 19:38
1  
@jsbillings even if you installed yum-priorities and have given precedence of one or the other? –  Nils May 3 '12 at 20:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.