Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem configuring my mail client on my Mac OS 10.6.8. These were the steps I did:

# touch ~/.fetchmailrc

I edited the file and created the contents:

poll pop.gmail.com with proto POP3 and options no dns
user 'GMAIL_USERNAME@gmail.com' there with password 'GMAIL_PASSWORD' is 'LOCAL_USERNAME'            
here and wants mda "/usr/bin/procmail -d %T"  options ssl keep sslcertck sslcertpath 

Then I executed:

# chmod 710 ~/.fetchmailrc

I copied the certificates from here http://af-design.com/blog/2010/04/28/using-linux-fetchmail-with-gmail/ into the directory ~/.ssl/certs/ and issued the following commands:

# ls ~/.ssl/certs/

    equifax.pem    gmail.pem   imap.gmail.pem

# c_rehash ~/.ssl/certs/

This generated the following files in the ~/.ssl/certs directory:

17974aab.0     578d5c04.0     b627f838.0     equifax.pem    gmail.pem      

It seems that I have the correct one as I didn't receive any complaints. Finally I ran the command:

# fetchmail -v

and got the error:

fetchmail: 6.3.11 querying pop.gmail.com (protocol POP3) at Thu, 03 May 2012 16:41:02    +0200 (CEST): poll started
Trying to connect to
fetchmail: Server certificate verification error: unable to get local issuer certificate
fetchmail: Certificate/fingerprint verification was somehow skipped!
fetchmail: SSL connection failed.
fetchmail: socket error while fetching from lgu.tbz@gmail.com@pop.gmail.com
fetchmail: 6.3.11 querying pop.gmail.com (protocol POP3) at Thu, 03 May 2012 16:41:02 +0200 (CEST): poll completed
fetchmail: Query status=2 (SOCKET)
fetchmail: normal termination, status 2

I tried to do as suggested in some forums, for example modifying the username or similar, but it did not help.

Any help is appreciated.

share|improve this question

according to this you shold go to your ~/.ssl/certs and:

wget -O Equifax_Secure_Certificate_Authority.pem  https://www.geotrust.com/resources/root_certificates/certificates/Equifax_Secure_Certificate_Authority.cer

then you have to run following line:

  c_rehash ~/.ssl/certs

then fechmail -v should not give Server certificate verification error.

share|improve this answer
Thanks for your answer, I don't use this method any more but should some user find it right and helpful it would be nice. Thanks for your answer!!! – Luigi Tiburzi Mar 25 '13 at 14:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.