Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

By default Kate inserts 2 spaces on Tab press but switches to real tabs starting from the fourth Tab level. Can I disable this and use spaces always, regardless to the depth?

I want this because I use Kate to code Scala, and using space pairs instead of tabs is a convention there.

share|improve this question
add comment

2 Answers 2

  1. Click the Settings menu
  2. Click "Configure - Kate"
  3. On the right expand "Editor"
  4. Click "Indentation"
  5. Uncheck "Use spaces instead of tabs to indent".

That works with Kate 2.5.10 (Using KDE 3.5.10) on Debian.

share|improve this answer
    
I use Kate 3.5.1 of KDE 4.5.1 with Gnome 2.32.0 and could find nothing of like this on the "Indentation" tab of its settings window. :-( –  Ivan Nov 11 '10 at 14:05
add comment

In 3.3.5:

  1. Click Settings menu.
  2. Click "Configure - Kate"
  3. Expand "Editor Component"
  4. Click "Editing"
  5. Click on "Indentation" tab on the right
  6. Change your Indentation width.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.