Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am unable to properly use dead key characters ( ' " ^ ) on (k)ubuntu 11.10 and 12.04 in arduino (a processing based application, at least version 0022 and 1.0).

Can I disable dead keys for specific application or application window, or does anybody know another work around?

'Dead keys' is the mechanism used to enter charactes like á ë ' ^, by first striking the accent-like key, then followed by a second key. The result is a combined character.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

I finally managed to figure out a work around. In KDE the keyboard configuration can be set in:

  • System Settings
  • Keyboard Settings
  • Layout
  • Select 'Show indicator'
  • Select 'Per window'
  • Add
  • Select a variant without 'dead keys', eg. "English (US, with Euro on 5)"

After applying these settings, I select the window for input focus and I click the indicator in the system tray when I want to switch the keyboard configuration. The keyboard setting needs only be set once per window and is rememberd over program restarts.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.