Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to setup Qubes OS on my desktop but struggling to get the network/internet working.

This is the configuration i want to setup -

ip -
Subnet -
Gateway -
interface - eth0

i tried following with limited success -

ifconfig eth0 netmask  
route add default gw

also edited /etc/resolv.conf to added dns entry.

Now when i check ifconfig - I get my ip & netmask configured and when i check routes i get 2 routes displayed with as default.

But i still cannot surf or even ping domains (eg. www.google.com).

Qubes has various security domains called AppVm's. So i guess we could/might need to setup a network config for each VM. Its all a little new to me (+ its documented sparsely) so any help appreciated!

share|improve this question
Since the network setup of Qubes OS is one of its defining characteristics (I guess), I suppose this can't be answered by someone not knowing it in detail. How about consulting the mailing list if the wiki doesn't help? – sr_ Apr 30 '12 at 9:15

The simplest way is to use NetworkManager system tray. Right-click on it, select edit connection, if the IPv4 tab, select manual and put your network settings in here.

share|improve this answer
How do you get to the NetworkManager? Is that the icon with two computers at the bottom right? If so while in dom0 I only have the option of clicking on 'VPN Connections' the two 'Ethernet Network' buttons are grayed out. – Mr. Tea Dec 27 '15 at 17:53

you need to assign the ipaddress using following format

Here is my Router (gateway)

auto eth0
iface eth0 inet static

you have to edit the resolv.conf for accessing the internet using and for permanent resolve you need to edit the base file too

vim /etc/resolv.conf

Append the below resovle


Edit the base file

vim /etc/resolvconf/resolv.conf.d/base

Append the below resovle

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.