Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

How do I make the cursor stop blinking when in a TTY? (or anywhere else).

BONUS Points for one universal setting that stops the cursor blinking almost everywhere.

share|improve this question
add comment

5 Answers

up vote 11 down vote accepted

This gives you a solid yellow block (nonblinking) as a cursor:

echo -n -e '\e[?17;14;224c'

For more info check these references: Linuxgazette and EmacsWiki as well as the file /usr/src/linux/Documentation/VGA-softcursor.txt (if present on your system)

share|improve this answer
    
this works for me until i use vim, then when i exit the cursor is back to blinking :( –  mulllhausen Sep 28 '13 at 4:48
add comment

There is a standard control sequence to turn off cursor blinking on terminals.

printf '\033[?12l'

However many terminals do not implement this setting, so read on.

There is a more widely implemented standard terminal setting for switching cursor visibility between high visibility, normal visibility and invisibility. Some terminals don't make a difference between normal and high, and there's no guarantee that one or the other will or will not blink. In terminfo, emit the cvvis, cnorm or civis string (e.g. tput cvvis). The corresponding termcap entries are vs, ve and vi.

These setting will not survive a terminal reset, so you may find that it doesn't survive the launching of many full-screen applications. You can overcome this difficulty by adding the cursor configuration changing sequence to your terminal's reset string.

  • On a terminfo-based system using ncurses, save your terminal's terminfo settings to a file with infocmp >>~/etc/terminfo.txt. Edit the description to change the rs1 (basic reset) sequence, e.g. replace rs1=\Ec by rs1=\Ec\E[?12l. With some programs and settings, you may need to change the rs2 (full reset) as well. Then compile the terminfo description with tic ~/etc/terminfo.txt (this writes under the directory $TERMINFO, or ~/.terminfo if unset).
  • On a termcap-based system, grab the termcap settings from your termcap database (typically /etc/termcap). Change the is (basic reset) and rs (full reset) sequences to append your settings, e.g. :is=\Ec\E[?12l:. Set the TERMCAP environment variable to the edited value (beginning and ending with :).

Some terminals and other applications give you more options:

  • The xterm cursor blinks if the cursorBlink resource is set to true or the -bc option is passed on the command line. The blink rate is customizable through the cursorOnTime and cursorOffTime resources.
  • Some other GUI terminal emulators can blink the cursor; check their configuration dialog box.
  • The Linux PC (VGA) console has a number of cursor settings; their exact meaning and applicability depends on the underlying VGA implementation (Linux framebuffer or video card). If your default cursor blinks, try turning the hardware cursor off and the software cursor on with something like printf '\033[17;127?c' (the first parameter 17 gives you the software cursor without a hardware cursor, and the second parameter set to 127 makes it essentially inverse video). See above regarding terminal resets.
  • In Emacs, M-x blink-cursor-mode toggles the cursor's blinking. Put (blink-cursor-mode 0) in your ~/.emacs to turn it off. This is a global setting and does not apply in a text terminal.

See also Juri Linkov (Jurta)'s No Blinking page for how to turn off blinking in Lesstif, Tk, Gtk (Gnome), Qt (KDE), Firefox, and more.

share|improve this answer
    
wow another extensive answer :) +1 –  NixNinja Nov 8 '10 at 10:12
add comment

I found this to be easier if you have root permissions:

~$ echo 0 > /sys/class/graphics/fbcon/cursor_blink

I put it in the machine startup script like /etc/rc.local for arch linux.

share|improve this answer
add comment

Put

\033[?17;0;127c

to your PS1 variable and you'll stop blinking constantly.

E.G:

export PS1='\033[?17;0;127c\u:\w\$ '

share|improve this answer
2  
I don't want to stop blinking, I want my cursor to stop ;) –  NixNinja Nov 4 '10 at 13:40
    
This will (at least for me) screw up the terminal line breaks (on line overflow). Use square brackets, escaped: For example, BLUEBOXNOBLINK="\033[?17;0;60c", then PS1="\[$BLUEBOXNOBLINK\]\[$BROWN\]\u \[$CYAN\]\W: \[$NC\]" –  Emanuel Berg Aug 13 '12 at 12:21
add comment

In the linux tty you can use the escape sequence "\e[?48;0;64" or whatever you like but this doesn't work in tmux/vim. Tmux/Vim issue a "cnorm" command on startup which by default contains a "\e[?0c". You can see that this undoes the effects of the above setting. You need to change cnorm to the above sequence in order for the TUI applications to reset the cursor to your preference. More info on this by Gilles but if you are looking for a quick fix try this:

infocmp linux > /tmp/linux-terminfo
# Replace the last escape sequence here with your colors and settings
sed -i 's/cnorm=\\E\[?25h\\E\[?0c/cnorm=\\E[?25h\\E?48;0;64c/' /tmp/linux-terminfo
tic /tmp/linux-terminfo

The last command will generate the new terminfo under ~/.terminfo which should be picked up automatically if you restart tmux server/vim.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.