Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install either Debian or CentOS on a home server (Fujitsu PRIMERGY TX100 S3). I first tried installing Debian. The whole installation was successful (including grub). But after rebooting, the OS would not boot up. My partition was the default setting for new users:

/dev/sda1 primary
/dev/sda5 logical (swap)

After booting, it gets to Intel Boot Agent and says it can't boot from media. I even tried disabling the DVD drive as a boot option. There is another device listed in boot options but the name is so ambiguous (IBA GE Slot 0200 v1372), I don't even know for sure if it refers to the hard drive.

I then tried CentOS, and the same problem occurred. I have looked around this website, some other StackExchange websites, and also general internet searching, and it seems that my problem is related to the boot process.

My problem is that I just don't know exactly where to begin looking. This is my first time setting up a Linux OS on a physical machine. Am I correct in assuming it is not reaching the BootLoader program properly? Or could this problem be caused by other things (ie, hardware)?

share|improve this question
Sounds stupid, but make sure you're installing the bootloader to /dev/sda. – Hello71 Apr 29 '12 at 2:05
Don't worry, I'm new to this. So it's a valid point to bring up. I actually tried manually installing the bootloader to /dev/sda1after it was not successful with /dev/sda. Any other suggestions? – penguin egg Apr 29 '12 at 3:35
You need to '@' this guy while replying .. but anyway , did you choose to boot from HDD ? – warl0ck May 29 '12 at 12:27
up vote 2 down vote accepted

Try to disable RAID controller in Advanced BIOS configuration and use standard AHCI or IDE SATA controller. This could help - from the boot menu there's more option including booting from disks.

share|improve this answer
Thanks, this was the issue. – penguin egg Aug 19 '12 at 20:35

It looks like you need a special driver for the hard disk.

If I google "Fujitsu PRIMERGY TX100 S3 CentOS" the first hit is a link to a whitepaper on CentOS on this server.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.