Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My dom0 is Gento 3.3.2, the kernel is compiled with Xen support. And I am planing to use the same kernel to boot my domU.

This is my domU configuration file:

  1 vif = [ 'bridge=xenbr0' ]
  2 vcpus = 1
  3 uuid = "c1d751ba-e228-45e6-b7a8-01895e88a815"
  4 root = "/dev/xvda ro"
  5 name = "Gentoo"
  6 memory = 512
  7 kernel = "/boot/kernel-3.3.2-gentoo"
  8 extra = "4 console=hvc0"
  9 disk = [ 'phy:/dev/vg/gentoo,xvda,w' ]

the /dev/vg/gentoo is a LV. After I ran xl create -c gentoo.cfg, the guest started and stopped with the following error (only the last few lines):

[    0.122019] netconsole: network logging started
[    0.122180] Root-NFS: no NFS server address
[    0.122186] VFS: Unable to mount root fs via NFS, trying floppy.
[    0.122280] VFS: Cannot open root device "xvda" or unknown-block(2,0)
[    0.123056] Please append a correct "root=" boot option; here are the available partitions:
[    0.123056] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)
share|improve this question
up vote 0 down vote accepted

It's been a while since I've used Xen, but when you say you've compiled your kernel with xen support do you have the xenblk driver/module? I think it's something like CONFIG_XEN_BLKDEV_FRONTEND in your .config. Have you tried any other xen configurations just to see if they work? For example, using the tap:aio interface?

share|improve this answer
I do have compiled the xenblk module. But I forgot to load them ;P – davidshen84 May 1 '12 at 5:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.