Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Okay, so I have a goal, and I'm unsure of the best steps to take to get there.

Goal:

  • Set up a Linux VM in VirtualBox (Host: Windows Server 2008 R2)
  • Setup Bacula in a Linux environment
  • Get Bacula to backup to a NAS device (preferably a Drobo as it's less expensive for us than other NAS solutions appear to be and we don't have time to build something like FreeNAS / ZFS)

Steps taken so far:

  • Created VirtualBox VM of Ubuntu Server (Maverick) as the guest
  • Installed KDE on Ubuntu
  • Updated packages, etc.
  • Installed Bacula -- no configuration, etc.

Steps that need to be taken, to my knowledge:

  • Install and run Bacula Administration Tool (bat)
  • Configure Bacula (either via bat or .conf files) -- backup to USB external HDD (to test backups, schedules, clients, etc.)
  • Re-configure Bacula storage daemon to backup to a network-attached Drobo device (i.e. Drobo FS)

Questions so far:

  • I see the following errors in the terminal and the bat tool when it starts -- why?

Terminal output:

Error: "/var/tmp/kdecache-sean" is owned by uid 1000 instead of uid 0.
(1893) KSharedDataCache::Private::mapSharedMemory: Opening cache "/var/tmp/kdecache-sean/icon-cache.kcache" page size is 4096
(1893) KSharedDataCache::Private::mapSharedMemory: Attached to cache, determining if it must be initialized
(1893) KSharedDataCache::Private::mapSharedMemory: Cache fully initialized -- attached to memory mapping
(1893) KSharedDataCache::Private::mapSharedMemory: 7323648 bytes available out of 10485760
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/sean/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address. 
IBusInputContext::createInputContext: no connection to ibus-daemon 

And on the console I receive: "bat: ABORTING due to ERROR in console/console.cpp:155 Failed to connect to localhost-dir for populateLists"

First Troubleshooting Avenues

This seems to me like bacula-dir isn't started? No configuration has been done, and I certainly don't pretend to know how to start Bacula properly.

I've tried consulting the documentation, to no avail for this particular implementation.

Any help? Thanks!

share|improve this question
add comment

1 Answer

I think that your first problem is related to bat running at root rather than as your "normal" user account. I'm guessing you started it using

sudo bat

or something similar. That is giving the warning messages that you see but I'm not sure that this is causing things to go badly wrong for you. Nothing in those messages tells me that bacula-dir is not running.

If you installed bacula using the Ubuntu packaged version then you can find out if the director is running using

/etc/init.d/bacula-director status

If you are just trialling things then I suggest that you start with the bacula-director-sqlite3 package. That doesn't need a separate database setup so it is much easier to get going. For production use you should use either the postgresql or mysql version.

Configuring a basic setup of bacula is fairly simple using the files installed by the Debian/Ubuntu packaging. Look in /etc/bacula directory. I'm not sure that bat actually allows configuration.

Once you have the director configured and started try your bat again (you need to make sure that /etc/bacula/bat.conf is configured too). If it still doesn't work and you suspect the errors due to it being run via sudo then try copying the bat.conf file into your own account and start bat using

bat -c /home/sean/bat.conf

That should get rid of the permissions errors.

If you have general configuration problems then the best place to ask for help is on the bacula-users mailing list that can be found via www.bacula.org

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.