Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I don't remember why they did this, but at one point X.org decided that disabling CtrlAltBackspace to kill it was a good idea. I know there's a way to re-enable it but I don't remember how. Can someone refresh my memory?

share|improve this question
add comment

4 Answers

up vote 15 down vote accepted

Modify /etc/X11/xorg.conf with the following. (note: it is ok if this is all you have in your xorg.conf as xorg will still auto-detect the rest (note: that is if auto-detect works for you without it))

Section "ServerFlags"
    Option "DontZap" "false"
EndSection

Section "InputClass"
    Identifier      "Keyboard Defaults"
    MatchIsKeyboard "yes"
    Option          "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
share|improve this answer
    
They seriously disabled this by default? No wonder it hasn't been working! –  gabe. Aug 13 '10 at 18:47
    
yes and it happened like 5 years ago. –  xenoterracide Aug 13 '10 at 18:54
5  
When you don't have to zap your xwindows very often, sometimes its easy to miss a change that happened 5 years ago... –  Bryan Rehbein Aug 16 '10 at 20:08
    
@Redbeard eh... xorg (and drivers) and kwin have been doing enough screwing around that I occasionally have to do it, and half the time I find out it's been disabled and I haven't re-enabled since my last reinstall. –  xenoterracide Aug 17 '10 at 18:30
    
@gabe. It's disabled by default because it's a potential security risk. For example, say the user logs in to the bare shell, starts X with startx, does some work, then locks the screen with xlock and leaves. Anyone can come along, zap X and get access to the user's shell on the tty. –  amphetamachine Nov 21 '11 at 21:59
show 2 more comments

you can try following ( I have tried it on my Ubuntu) :

Add the following lines to your xorg.conf file, making sure that when you paste it, it is NOT using smart quotes.

sudo gksudo gedit /etc/X11/xorg.conf

Section "ServerFlags"
Option "DontZap" "false"
EndSection

you can also try dontzap tool

sudo apt-get install dontzap

Open Terminal and type to enable

sudo dontzap --enable

for disable

sudo dontzap --disable

share|improve this answer
    
I really wish they had never turned this off by default. oh, and apt-get doesn't work on my system ;) apparently we haven't packaged dontzap either. oh well. –  xenoterracide Aug 12 '10 at 7:20
    
did you try first solution ? –  Hemant Aug 12 '10 at 7:28
    
setxkbmap -option terminate:ctrl_alt_bksp by itself that didn't work :( apparently you need to do this too. –  xenoterracide Aug 12 '10 at 7:29
    
@Hermant of course but it seems to be only 1/2 of it. I actually have it working now... there's a way to configure the xsetkbd option in xorg.conf. like so Section "InputClass" Identifier "Keyboard Defaults" MatchIsKeyboard "yes" Option "XkbOptions" "terminate:ctrl_alt_bksp" EndSection there are several other places it could be done too. –  xenoterracide Aug 12 '10 at 9:55
    
It will be gr8 if you can put your solution as Answer. So that others facing same issue can get help :-). –  Hemant Aug 12 '10 at 10:06
show 2 more comments

http://who-t.blogspot.com/2009/04/zapping-server.html explains the change and how to change it back.

share|improve this answer
add comment

The DontZap feature is no longer working for me on Fedora 16 and Ubuntu 11.10 (most recent releases as of November 2011), so I found an alternative.

According to the X11R7.5 release notes, it appears that this functionality has been migrated to a XKB configuration option, therefore DontZap no longer works. I can't tell if this is a detail of the Xorg implementation in Fedora and Ubuntu, or if this affects other distros as well.

From http://www.x.org/archive/X11R7.5/doc/RELNOTES.txt

Terminate Server keystroke

The Xorg server has previously allowed users to exit the server by pressing the keys Control + Alt + Backspace. While this function is still enabled by default in this release, the keymap data usually used with Xorg, from the xkeyboard-config project, has been modified to not map that sequence by default, in order to reduce the chance that inexperienced users will accidentally destroy their work.

Users who wish to have this functionality available by default may enable it via the XKB configuration option “terminate:ctrl_alt_bksp”. For instance, the setxkbmap command can be used to enable this by running:

       setxkbmap -option "terminate:ctrl_alt_bksp"                       

Many desktop environments include XKB configuration options in their preferences to enable this as well.

share|improve this answer
1  
my answer still works as of 7.6 –  xenoterracide Nov 22 '11 at 7:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.