Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Gnome desktop notifications of new updates is not working on my system. I noticed that the notifications stopped working when I removed my desktop user from the sudo group (I prefer to have a separate user with sudo privileges). I found the following post in Debian bugs which suggests that it is necessary for the desktop user to be in the sudo group for the updates notifications to work:


The update-notifier man page mentions the following commandline option:

--force "Force start even if the user is not in the admin group."

Should I consider adding the above option to update-notifier in the startup applications list? Doing "ps aux | grep update" shows that update-notifier is already running, so perhaps it is another process that is the source of the problem?

Thanks in advance for any assistance.

  • Debian Squeeze
  • 2.6.32-5-686
  • update-notifier 0.99.3debian8
share|improve this question
Have you had a look at its output (in .xsession-error or by running update-notifier from a terminal)? – sr_ Apr 27 '12 at 7:55
.xsession-error doesn't mention anything of update-notifier. I tried "--force" in the startup applications command & got the grey star icon of update-notifier in the notification area temporarily, so that bodes well that it's now functioning. While the grey icon was visible I piped the output from 'ps aux' to a file and grep'd for "update" & got "/usr/bin/python /usr/lib/update-notifier/apt-check" and "apt-get -qq -y update" and " update-notifier --force". When new security updates are released, I will post here whether the red "updates are available" update-notifier icon shows. – Toby Apr 28 '12 at 0:59
I ran 'update-notifier' on the commandline, but just get the error: (update-notifier:2469): WARNING : already running? – Toby Apr 28 '12 at 1:03
I can confirm that adding "--force" to the update-notifier command in startup applications fixed the problem. The update-notifier red star notification appeared on the desktop to notify of new updates. Clicking on the red star prompted me for the administrator password to install the updates, which is the behaviour I was looking for. Thank you @sr_ – Toby May 2 '12 at 2:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.