Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

I have a Mini-PC with an ASRock AD2700B-ITX motherboard, which has an Intel PowerVR SGX545 on-board graphic chip. I installed Ubuntu 12.04 on it today.

Everything is working properly and is quite quick and responsive, except that the video resolution is too low. I cannot set it higher than 1280x1024. I have a BenQ G2220HD display, which is capable of 1920x1080.

Since both the graphics chip and the display are capable of higher resolutions, I assume this is a driver problem?

share|improve this question
can you confirm this is not supported natively by ubuntu? I was gonna get this chip too. also this the graphic card should be SGX545. NOT SGX454 as you mentioned above! –  c2h2 May 16 '12 at 16:25

2 Answers 2

I think the answer you got in your forum post is correct: if doesn't have a chipset-specific driver, it's going to fall back to the generic VESA driver, which may not support all of the functions of that graphics chip.

I looked in the manual for that motherboard, and it is very sketchy on graphics issues. It claims "up to 1920x1200" but doesn't justify that with a video memory spec. Given the nature of the Atom and PowerVR, I'd bet it's taking a slice of system RAM for a video buffer, but I don't see anything in the UEFI section of the manual on configuring its size.

You could try forcing X to recognize the video RAM. Say sudo nano /usr/share/X11/xorg.conf.d/99-vesahack and put this in the newly created file:

Section "Device"
    Identifier "Screen0"
    VideoRam 9000

This tells X that there is 9 MB of video RAM, enough for 1920x1200 at 4 bytes per pixel. If X won't restart when you do that, try changing it to 6750 kB, for 3 Bpp. I don't hold out much hope that this will work, but it's a thing to try. If it doesn't help, remove 99-vesahack.

Your best option may be to install a graphics card known to have good support.

share|improve this answer

I have that same motherboard / OS setup and I'm using the cedarview drivers. I achieve full resolution but performance in 2D isn't brilliant.

quoting original article

There is a ppa repository with drivers for ubuntu 12.04 at With the following steps, you can get accelerated X working with the Intel Cedarview Chipset on Ubuntu 12.04:

  • Just add the repository to your APT:

    $ sudo add-apt-repository ppa:sarvatt/cedarview
  • Install the add-apt-key utility

    $ sudo apt-get install add-apt-key
  • Install the Repository KE

    $ sudo add-apt-key 0x4c96de60854c4636
  • Make apt-get update

    $ sudo apt-get update
  • Make apt-get upgrade to verify that your system is up2date

    $ sudo apt-get update
  • You can try to Add "video=LVDS-1:d" to GRUB_CMDLINE_LINUX_DEFAULT variable, if your don't see anything remove it... on one of my Systems it's working, on a second device it doesn't.

    $ sudo vi /etc/default/grub
  • if you're using PAE kernel, remove it and install generic kernel

    $ sudo apt-get install linux-headers-generic linux-image-generic
    $ sudo apt-get remove linux-headers-generic-pae linux-image-generic-pae
  • Install the cedarview drivers

    $ sudo apt-get install cedarview-drm libva-cedarview-vaapi-driver cedarview-graphics-drivers
  • Change Option "AIGLX" to "Off" because 3D isn't working (default section)

    $ sudo vi /usr/share/intel-cdv/X11/xorg.conf.d/61-cdv-pvr.conf
  • Update the Grub Bootloader

    $ sudo update-grub2
  • Reboot the System

    $ sudo reboot

Seems that the manufacturer doesn't really care much about releasing Linux drivers for this chipset, it is a shame, it is a good-ish machine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.