Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

What patchlevel does this SLES machine has? 10.2 or 10.4?

SERVER:~ # cat /etc/issue
SUSE LINUX Enterprise Server 10.2
Kernel \r (\m), \l
SERVER:~ # 

SERVER:~ # cat /etc/SuSE-release 
SUSE Linux Enterprise Server 10 (x86_64)
VERSION = 10
PATCHLEVEL = 4
SERVER:~ # 

UPDATE:

SERVER:/etc # rpm -V sles-release
S.5....T  c /etc/issue
S.5....T  c /etc/issue.net
S.5....T  c /etc/motd

SERVER:/etc # zypper sl
# | Enabled | Refresh | Type | Name                                                | URI                                                                   
--+---------+---------+------+-----------------------------------------------------+-----------------------------------------------------------------------
1 | No      | No      | YaST | SUSE Linux Enterprise Server 10 SP2                 | cd:///?devices=/dev/hda                                               
2 | Yes     | Yes     | YaST | SUSE Linux Enterprise Server 10 SP2-20110317-171027 | nfs://123.123.123.123/usr/sys/inst.images/Linux/SuSE/SLES10_x86_64/10.2

SERVER:/etc # uname -r
2.6.16.60-0.91.1-smp

UPDATE #2:

SERVER:/etc # cat /etc/issue.rpmnew

Welcome to SUSE Linux Enterprise Server 10 SP4  (x86_64) - Kernel \r (\l).

UPDATE #3

SERVER:/etc # 

SERVER:~ # rpm -qi glibc
Name        : glibc                        Relocations: (not relocatable)
Version     : 2.4                               Vendor: SUSE LINUX Products GmbH, Nuernberg, Germany
Release     : 31.95.1                       Build Date: Mon Sep 19 16:43:25 2011
Install Date: Sun Mar 18 08:01:27 2012      Build Host: macintyre
Group       : System/Libraries              Source RPM: glibc-2.4-31.95.1.src.rpm
Size        : 5141247                          License: BSD 3-Clause; GPL v2 or later; LGPL v2.1 or later
Signature   : DSA/SHA1, Mon Sep 19 16:45:00 2011, Key ID a84edae89c800aca
Packager    : http://bugs.opensuse.org
URL         : http://www.gnu.org/software/libc/libc.html
Summary     : Standard Shared Libraries (from the GNU C Library)
Description :
The GNU C Library provides the most important standard libraries used
by nearly all programs: the standard C library, the standard math
library, and the POSIX thread library.  A system is not functional
without these libraries.
Distribution: SUSE Linux Enterprise 10
SERVER:~ # 
share|improve this question
    
rpm -qi glibc shows which version? –  Nils Apr 28 '12 at 19:42
    
I updated with UPDATE #3 –  LanceBaynes Apr 29 '12 at 10:32
    
This is a SLES10 SP4, too. –  Nils Apr 29 '12 at 19:47

2 Answers 2

up vote 3 down vote accepted

Most probably you have got a SLES10 SP4.

Do a rpm -V sles-release - if /etc/SuSE-relase does not show "5" (i.e. changed md5-checksum) the file content is original.

If you update your question with your exact kernel version (uname -r) I can even tell you more.

You can also check which repositories are active on that system: zypper sl

Update on uname/zypper results:

Here is a list of SLES-kernels and their release dates. This shows your kernel to be a SLES10 SP4 released on 2011-10-28. There is a more recent SP4 kernel from 2012-01-23.

Your output from zypper sl puzzles me. I can not see how your system got to SLES10 SP4 - there are only SLES10 SP2 repositories shown.

I think it is worth to look into this a bit deeper... (see my current comment to your question)

share|improve this answer
    
I will update my question, ty! –  LanceBaynes Apr 28 '12 at 5:22
    
So is it sure that it's 10.04? –  LanceBaynes Apr 28 '12 at 5:28

Both files are part of the sles-release package, see rpm -qf /etc/SuSE-release /etc/issue.

That command will output which version of that package you have installed.

I suspect that you have modified /etc/issue and the latest update will have created a file /etc/issue.rpmnew. Changes are that file says 10.4.

So that would indicate you have SLES 10.4.

But you should not rely on those files too much. For SLES you need to check which repositories are configured in yast. I'm no SLES expert so I can't help with that part but it should get you started.

Here is page showing how to update a SLES system between various SP's.

share|improve this answer
    
I did updated to the question in "update #2", ty! –  LanceBaynes Apr 28 '12 at 5:27
    
So is it sure that it's 10.04? –  LanceBaynes Apr 28 '12 at 5:27
    
No, from the output in update 1 I'd say you've got the SP2 repositories configured. I don't know enough of SLES specifics to explain how you got the 10.4 release rpm installed though. But I do know (from RHEL) that the release rpm is just another rpm, it has no special magic. If you install SP2 and then install only the SP4 release rpm your system is still SP2 but it "looks" to be SP4. That's what I meant when I said you shouldn't rely on this too much. This is a difference between RHEL and SLES, SLES has distinct repositories for different SP's and you need to point to the right repository. –  Bram Apr 29 '12 at 9:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.