Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I follow various bugs on Red Hat Bugzilla, and I just received a notification from the Fedora Update System that a new package was available for testing that supposedly fixes a bug I was interested in. I wanted to test it, so I tried to follow the instructions.

Unfortunately, although the packages are described as having been "pushed to updates-testing", I see no evidence that they are actually there yet. It seems somewhat silly to publish a command for testing an update that initially doesn't work, but this is apparently what they are doing on a regular basis!

I tried a couple of things:

  1. Commented out mirrorlist and uncommented base-url in /etc/yum.repos.d/fedora-updates-testing.repo to make it use (what I believe to be) the "master" public download site
  2. yum clean all

but these made no difference to the outcome - still no new packages available, according to yum.

Details: It's mesa-libGL (and the other mesa packages) for Fedora 14.

share|improve this question
    
Sanity check: did you run yum update? –  Gilles Nov 3 '10 at 7:56
    
@Gilles: Yes - that's the command I was told to use (with some arguments). Remember, yum update is not the same as apt-get update - yum does what apt-get update does automatically. It works now, but it didn't last night. –  Robin Green Nov 3 '10 at 8:19
    
The Fedora Update System now posts messages which clearly state that there may be a delay of up to two days. I'm pleased that the messages are now more accurate! –  Robin Green Jun 11 '11 at 8:30
add comment

1 Answer

up vote 2 down vote accepted

By default, you can use:

yum clean expire-cache
yum repolist -v updates-testing

...which will show you both the last time that Fedora updated (in the metalink/updated row) and the last time you updated (in the repo-updated row). As a quick check you can also just run "yum repolist" on it's own, and any rows that start with a '*' do not have the latest metadata locally.

AIUI Fedora post the messages about packages being pushed as they are approved ... but it can still be a non-trivial amount of time after that before they are in the Fedora repo. (and longer for your local mirror to sync.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.