Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have configure, gmake, and gmake installed syslog-ng-3.4.0alpha1 with eventlog-0.2.12 and other dependencies.

From then output of the ./configure --prefix=/syslog --with-gnu-ld, I can see that the configure script is passing the compiler option -pthread and the linker flag -lpthread.

 syslog-ng Open Source Edition 3.4.0alpha1 configured
 Compiler options:
  compiler                    : gcc -std=gnu99
  compiler options            : -g -O2 -Wall -pthread  -D_REENTRANT -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include   -I/usr/local/include/eventlog       -I$(top_srcdir)/lib/ivykis/lib/include -I$(top_builddir)/lib/ivykis/lib/include -I$(top_srcdir)/lib/ivykis/modules/include -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
  linker flags                :  -lpthread
  prefix                      : /syslog
  linking mode                : dynamic
  __thread keyword            : no
 Submodules:
  ivykis                      : internal
  libmongo-client             : internal
 Features:
  Debug symbols               : no
  GCC profiling               : no
  Memtrace                    : no
  IPV6 support                : yes
  spoof-source support        : no
  tcp-wrapper support         : no
  Linux capability support    : no
  PCRE support                : no
  Env wrapper support         : no
  systemd support             : no (unit dir: none)
 Modules:
  Module search path          : /syslog/lib/syslog-ng
  Sun STREAMS support (module): yes
  SSL support (module)        : no
  SQL support (module)        : no
  PACCT module (EXPERIMENTAL) : no
  MongoDB destination (module): yes
  JSON support (module)       : parser=no, formatter=no (using no)
  SMTP support (module)       : no

Is this the cause of the error? And if so, how do I stop syslog from compiling with these options?

share|improve this question
    
I've done a bit more digging and it looks like my glib was compiled without the --with-threads=posix flag. I'm trying to reconfigure now but running into trouble. Can anyone tell me if that sounds like at least the right direction? –  emhohensee Apr 25 '12 at 16:18
add comment

1 Answer

Three notes:

  • you should use a current git snapshot instead of alpha1, as alpha1 crashes on start-up.
  • please ask on the syslog-ng mailing list, as there are more people to answer your question, including syslog-ng developers.
  • even current git needs a patch, see this thread on the mailing list: 3.4 on opensuse factory
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.