Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Is it possible to use a module (wacom) from a more recent kernel ? My current kernel is 3.1.2 and the module is from kernel 3.4rc4.

share|improve this question

1 Answer 1

It varies, sometimes the dependencies of a kernel module has changed too much but for the wacom module it does not matter.

By the way, you can get the wacom kernel module source from I recommend you to use DKMS for building custom kernel modules. I've packaged a package for Ubuntu: If you're not familiar with Ubuntu or Debian packaging, the .debian.tar.gz file contains packaging scripts.

share|improve this answer
So, if I compile only the wacom module it may work ? by the way i am using opensuse and i am trying to make Intuos5 tablet work. –  igor012 Apr 24 '12 at 14:35
It should work, the kernel requirements are still like 2.6.37 –  Lekensteyn Apr 24 '12 at 14:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.