Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Vim scripts sometimes resize the whole shell (in my case the Taglist plugin).

I don't want this behavior, which is possible with the shell command resize, too.

Is there a way to suppress the whole resizing in shell windows? Any .*rc files to tune?

I'm using gnome-terminal.

share|improve this question
    
xterm has a preference to ignore "window ops", the control codes that move/resize the window. I don't see anything like this mentioned in the Gnome terminal manual, but you might try looking for something like that. –  Chris Page Jun 29 '12 at 13:46
add comment

2 Answers

up vote 1 down vote accepted

To fix your Taglist issue, add the following somewhere in your .vimrc:

let Tlist_Inc_Winwidth=0

From the VIM documentation:

Window resizing with xterm only works if the allowWindowOps resource is
enabled.  On some systems and versions of xterm it's disabled by default
because someone thought it would be a security issue.  It's not clear if this
is actually the case.

To overrule the default, put this line in your ~/.Xdefaults or
~/.Xresources:

    XTerm*allowWindowOps:       true
     (note: this actually ENABLES it, you want to DISABLE, ie: false)

And run "xrdb -merge .Xresources" to make it effective.  You can check the
value with the context menu (right mouse button while CTRL key is pressed),
there should be a tick at allow-window-ops.

From my own experience with the Xresources, if you drop the 'XTerm' part, and just lead with the asterisk, it should also apply for any gnome terminals too. The gnome terminal has it's particular prefix, but I don't know it, maybe someone could comment with that info, but the *allowWindowOps: false line should help.

share|improve this answer
add comment

Just a shot in the blue, but does

shopt -s checkwinsize off

work?

share|improve this answer
    
this doesn't work - and shopt -u checkwinsize has no effect. –  David Halter May 1 '12 at 2:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.