Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I messed something up and can't get my touchpad functional at all on GNOME 2.30 any more. I looked at Mouse Preferences on the Touchpad tab, and can't find the magic switch. The touchpad works on the Virtual Terminals, and on LXDE.

Here's output from dmesg, after running sudo modprobe psmouse:

[29186.004285] Synaptics Touchpad, model: 1, fw: 6.3, id: 0x9280b1, caps: 0xa04793/0x304000/0x0
[29186.004295] serio: Synaptics pass-through port at isa0060/serio4/input0
[29186.041853] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio4/input/input22
[29191.135029] input: PS/2 Generic Mouse as /devices/platform/i8042/serio4/serio9/input/input23
share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

This is probably a problem with GConf.

With gconf-editor, reach the /desktop/gnome/peripherals/touchpad "folder" and make sure touchpad_enabled is ticked.

I've set this value as mandatory because for some reason this value kept getting disabled. This hasn't happened since.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.