Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have been struggling with this issue for a while and have done an exhaustive search for answers here and elsewhere before posting this question.

On my Asus X101H, the touchpad is not recognized as a touchpad. I have noticed that this problem does not only occur with my netbook, or Asus netbooks, but a whole host of netbooks.

The devices are identified as "Glidepads". From what I have gathered, it is a kernel issue. And it is up to those working on the kernel to be resolved. However, people making bug reports on this issue have had issues with them being closed without being resolved, etc.

All I want is for this miserable "glidepad" to be disabled while I am typing so it doesn't ruin what I am trying to write. On my notebooks, it works fine. But on netbooks, the only options present are for a mouse.

I tried everyone's suggestion of installing "gpointing...", but that doesn't work even when I choose to "disable touchpad while typing". It has no effect.

Does anyone have a solution for this issue? It affects Ubuntu, Kubuntu, Debian, and Mint (and probably many, many more.)

share|improve this question

2 Answers 2

Try running sudo modprobe -r psmouse and report how it went. It solved issue for me. If you want to enable it again run sudo modprobe psmouse proto=imps, also you can make a simple script with these commands that controls enabling/disabling touchpad this way.

share|improve this answer
    
that disables the "Glidepad" which is, of course, registered as a mouse. –  Musaab Apr 22 '12 at 22:30
    
I just want it to be disabled while I am typing. –  Musaab Apr 22 '12 at 23:47
    
I had problems with touchpad on my Asus K52F laptop. I couldn't turn it on or off when I wanted. The solution above settled the issue (I have little script that I run when I want to turn on/off the touchpad). –  Petar A. Apr 23 '12 at 7:33
    
What was the command to load it back up? –  Musaab Apr 23 '12 at 11:59

My solution is not very different, but instead of unloading and loading the module, you can interface with xinput. If you list xinput devices and find your device:

$ xinput --list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                    id=4    [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                         id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                   id=5    [slave  keyboard (3)]
    ↳ Power Button                                  id=6    [slave  keyboard (3)]
    ↳ Video Bus                                     id=7    [slave  keyboard (3)]
    ↳ Sleep Button                                  id=8    [slave  keyboard (3)]
    ↳ Integrated Camera                             id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard                  id=10   [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                        id=12   [slave  keyboard (3)]

So if I wanted to disable the trackpoint (just look for the ID), I could do so with the following command:

xinput set-prop 11 "Device Enabled" 0

To re enable it, just change from '0' to '1'.

There is also a synclient feature called palm detection, that might be able to help you. I haven't tested this myself, so I can't vouch for it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.