Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm struggling to make the cursor in bash stop blinking. Also, the cursor in Iceweasel has started blinking again, but, for some reason, a lot slower than in bash :) I got those problems since I upgraded to sid, so probably some configuration files were overwritten.

I tried everything in How to stop cursor from blinking - nothing worked, probably because that was about tty, not bash.

This did not work (that is, setting the flags worked, just didn't do anything to the cursors):

gconftool --search-key cursor_blink
 /desktop/gnome/interface/cursor_blink = false
 /schemas/desktop/gnome/interface/cursor_blink = false

This did work, but only to make the cursor visible and invisible, it didn't stop the blink:

tput cvvis

This did not work:

echo -n -e '\e[?17;14;224c'
printf '\033[?12l'

My PS1 looks like this (added \033[?17;0;127c):

PS1="\033[?17;0;127c\\[$(tput setaf 3)\\]\u \\[$(tput setaf 4)\\]\w: \\[$(tput sgr0)\\]"

This is already set to zero:

/sys/class/graphics/fbcon/cursor_blink

Any more ideas?

share|improve this question
1  
bash has no say over cursor blink; it's up to the terminal emulator you're using. If sid is running GNOME 3 like wheezy is, the configuration is in dconf instead of gconf; I don't know what the new settings would be off the top of my head, though. – geekosaur Apr 22 '12 at 10:49
    
OK! I don't have dconf, and aptitude cannot install it because dpkg complains it cannot find ldconfig and start-stop-daemon. Those are unfamiliar to me, but an aptitude search did not show any results. Speaking of GNOME 3, do you know how to check what version I'm running? – Emanuel Berg Apr 22 '12 at 11:01
    
If you're logged in, ps -fu$USER | grep gnome-shell. Although that's imperfect as you could be in fallback mode, and as far as I've been able to determine GNOME ignores all its settings in that case. – geekosaur Apr 22 '12 at 11:05
    
There is no gnome-shell line but a gnome-terminal that looks like this: incal 2997 1 0 12:03 ? 00:00:04 gnome-terminal - Is that what you meant? You lost me :) – Emanuel Berg Apr 22 '12 at 11:16
    
No; gnome-shell is the fancy new GNOME 3 UI manager, replacing gnome-panel and a number of other independent programs used by GNOME 2. I don't know how to detect fallback mode, though — it looks like GNOME 2 except it seems to ignore settings. – geekosaur Apr 22 '12 at 11:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.