Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have no idea how I modified vim such that all braces are highlighted, not just matching ones, but I want to turn it off now. How do I do that? The usual highlighting of matching braces works fine.

share|improve this question

closed as off-topic by Jeff Schaller, Stephen Kitt, MelBurslan, Jakuje, jimmij Apr 5 at 19:01

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Stephen Kitt, MelBurslan, Jakuje, jimmij
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Obviously, you forgot to mention in what editor is this behavior. – alex Nov 2 '10 at 11:50
2  
@alex obviously he tagged it vim – xenoterracide Nov 2 '10 at 12:01
1  
@xenoterracide: ok, my bad. Still putting it straight from the start wouldn't hurt anybody, and tags are very easy to overlook, IMHO. – alex Nov 2 '10 at 13:48
2  
What happens if you :syn off? – ephemient Nov 2 '10 at 23:52
    
It turned up out of nowhere and it disappeared by itself, – matcheek Nov 9 '10 at 2:17

Remove your ~/.viminfo file and start again.

share|improve this answer

It could be a plugin called pi_paren. You should be able to turn it off by executing NoMatchParen (and DoMatchParen to turn it back on).

If you want to turn it off permanently, add (to your .vimrc):

NoMatchParen
share|improve this answer
    
not this one either unfortunately.The quest continues. – matcheek Nov 19 '10 at 16:18

Did you do a search for a brace? If you did then you can either search for gibberish, or you can do a :set nohlsearch to turn off highlighting.

share|improve this answer
    
That was my first thought. No, it's something else. – matcheek Nov 2 '10 at 16:45
    
Or :let @/ = '', which will clear the search pattern so you can leave hls on. (Even if it apparently doesn't matter, for OP) – ephemient Nov 2 '10 at 23:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.