Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I try to install bluetile in archlinux, I get the following error:

 Building glade-0.12.1...
 Preprocessing library glade-0.12.1...
 gtk2hsC2hs: UName: root name supply used after saving
 cabal: Error: some packages failed to install:
 bluetile-0.6 depends on glade-0.12.1 which failed to install.
 glade-0.12.1 failed during the building phase. The exception was:
 ExitFailure 1

I'm using the ArchLinux Wiki install instructions.

share|improve this question

1 Answer 1

According to a thread on gmane.comp.lang.haskell.gtk2hs.devel, the problem is with gtk2hs-buildtools-0.12.3. 0.12.1 doesn't have the problem.

I fixed the issue myself by installing 0.12.1:

cabal install gtk2hs-buildtools==0.12.1

and the error you describe goes away.

share|improve this answer
    
Thanks, but now I get cabal: The program alex is required but it could not be found. Error: some packages failed to install... Which is weird, because I HAVE alex installed! –  drozzy May 8 '12 at 18:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.