Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Ubuntu-Server 12.04, but I wasn't sure if this was an Ubuntu specific question, so I'm posting it here.

I got myself a graphical user interface by installing xinit and openbox (using apt-get install). I installed guake as well (again using apt-get install). However, when I try to run guake in my terminal emulator (Sakura), I get the following error message:

Traceback (most recent call last):
  File "/usr/lib/guake/guake.py", line 1356, in <module>
    if not main():
  File "/usr/lib/guake/guake.py", line 1299, in main
    instance = Guake()
  File "/usr/lib/guake/guake.py", line 649, in __init__
glib.GError: GDBus.Error: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files

How can I fix this and get guake to run?

share|improve this question
up vote 4 down vote accepted

This report indicates it's sudo apt-get install notification-daemon.

share|improve this answer
When I run the command I get notification-daemon is already the newest version. – math4tots Apr 20 '12 at 3:21
Actually, on reboot, it seems to work... – math4tots Apr 20 '12 at 5:27

You need to install and run DBus; specifically you want to use dbus-launch to run your X11 session. apt-get install dbus-x11 should install the daemon components and dbus-launch.

share|improve this answer
When I run apt-get install dbus-x11, it tells me dbus-x11 is already the newest version. When I run apt-get install dbus-launch, it tells me E: Unable to locate package dbus-launch – math4tots Apr 20 '12 at 3:05
Ok, so it's installed already, you just need to use it. See man dbus-launch for how to integrate it into your openbox session. – geekosaur Apr 20 '12 at 3:07
I think the error message shows that dbus is running properly, but the expected endpoint is missing. – Gilles Apr 20 '12 at 23:22
Argh. Yes, not sure what I was thinking yesterday. dbus is there, notification service is missing. – geekosaur Apr 20 '12 at 23:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.