Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to use qmake in a samba mounted directory. Here is what I get

jj@deb32-6:~/smbShare$ qmake .
QFSFileEngine::currentPath: stat(".") failed
QFSFileEngine::currentPath: stat(".") failed
QFSFileEngine::currentPath: stat(".") failed
QFSFileEngine::currentPath: stat(".") failed
Cannot find file: ..

qmake works in any other directory. I'm using debian 6.0.4 32-bits with kernel 2.6.32-5-686. My qmake is from Qt 4.7.4 built from sources.

Any idea ?

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

Ok I've found the solution : mount the directory using cifs rather than smbfs, and it works ! I added the following line to fstab :

//windows-computer/share    /home/jj/smbShare   cifs username=jj,password=***,perm,iocharset=utf8,uid=jj,gid=users,nounix,noserverino  0  0

To avoid putting your Windows password in the fstab file, you may use a credential file : http://anothersysadmin.wordpress.com/2007/12/17/howto-mount-samba-shares-in-fstab-using-a-credential-file/

share|improve this answer
1  
Since you found the solution, you should accept your own answer so others know it is resolved. Perhaps also put an example in the answer of how you mounted with CIFS. –  uther Apr 19 '12 at 20:16
    
Sure, but I have to wait 2 days before I can do that :-). –  Julien Apr 20 '12 at 6:45
    
Thanks for sharing this. For me, just doing a "mount -t cifs ..." from the command line was resulting in the same error when I did a qmake. Adding the mount to fstab with the arguments you showed did the trick for me. –  LatencyMachine Nov 19 '13 at 2:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.