Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a clean Linux Mint 12 install on a Lenovo R61i laptop. I have multiple users configured - one for myself, my wife, and my daughter. My account is the only sudoer.

Two or three times a week the machine "crashes" when switching users, seemingly only when both users are already logged in. Once the user has requested a switch, typed their password, and hit enter, they are presented with a black screen with a flashing white cursor in the top-left. No matter how long one waits, this screen does not change. The only way I've found out of this situation is to hold down the power button until the machine shuts off, then start her up again.

I should point out that we switch users often, most of the time without any issue at all. So it's difficult to reproduce.

I've had a search around but haven't been able to determine whether this is a known issue or not. Can anyone offer any advice on how to rectify this?

UPDATE: I just had the "crash" again, and tried various key combinations to see if I could get any response whatsoever. Turns out that Ctrl+Alt+Del briefly printed out some standard shutdown messages (too fast for me to relay, I'm afraid) and then restarted the machine.

Still eager for a solution to this issue.

share|improve this question

closed as off-topic by Braiam, Renan, jasonwryan, peterph, vonbrand Feb 7 at 1:27

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Braiam, Renan, jasonwryan, peterph, vonbrand
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
I don't use Linux Mint, but I do use Ubuntu (10.04). Have you checked if there's something unusual in "log files" in the /var/log directory? I'm guessing the most important files to watch would be /var/log/messages and/or /var/log/syslog but there may be others relevant to debug this. –  ricmarques Apr 21 '12 at 13:55
5  
This sounds like it tried to switch virtual consoles and start or resume a different X server. I expect that something will be logged either in the aforementioned logs or /var/log/Xorg.1.log, and that Ctrl+Alt+F7 might work to get you back to the original desktop, or Ctrl+Alt+F1 to get to a text console login: prompt. –  geekosaur Apr 23 '12 at 7:15
    
Yeah, C-A-F1 to F6 should have text terminals, and C-A-F7 onwards should have you graphical terminals, one for each user. Try it now and you should see that unused terminals have a flashing cursor like you describe. –  ams Apr 25 '12 at 12:56
1  
Whilst Ctrl+Alt+F7 successfully got me from the flashing cursor screen back to my desktop, I then got an entirely different problem. It's difficult to explain, but basically all I could do is Alt+Tab to cycle between my open apps, but none of them would actually open. My desktop was rendered strangely, and clicking and other keyboard input seemed ineffectual. I again seemingly had no choice but to power off the machine :( –  Kent Boogaart May 5 '12 at 17:09
1  
Just switched to Mint13 with Cinnamon and not being able to switch users at all definitely solves the problem for me! ;) –  Kent Boogaart Jun 5 '12 at 8:07

Browse other questions tagged or ask your own question.