Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've recently updated my gnome to 3.4 and a problem appears.

When I start scrolling, scroll never ends and even continues to scroll when I switch to another window.

How can I disable this annoying feature?

I run gnome on ArchLinux with kernel 3.3

share|improve this question
    
Doesn't sound like a feature...considered filing a bug report? (Maybe there is one already.) -- If you used Arch's packages, maybe this is the place to go. –  sr_ Apr 18 '12 at 7:09
    
It is certainly a bug, but seems like the auto-scrolling feature has been added to gnome 3.4, so maybe there is an option to disable it. –  Ben D Apr 18 '12 at 7:21

2 Answers 2

up vote 2 down vote accepted

Seems like it was a problem with the synaptics touchpad driver. I've installed gsynaptics and unchecked the continue scrolling checkbox in the Scrolling tab, and that fixed the problem.

share|improve this answer

I found a solution without installing that software:

  • edit /etc/X11/xorg.conf.d/10-synaptics.conf
  • add the line

    Option "CoastingSpeed" "0"
    

I'm also having some problems scrolling in nautilus. Scrolling is not working on folders either in dconf-editor for instance.

share|improve this answer
    
I have the same problem. It works sometimes though (very rarely)... –  tjameson Apr 27 '12 at 9:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.