Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have up to date gentoo system with kvm images located on 500 gb partition with 200 gb of free space and defragmented, running machine with Windows XP and 2gb ram, I have problem with making snapshot of runing vm.

When I try to save state via the savevm command using qemu monitor it starts to use 100% of disk IO and writes data very slowly (<1mb/s). It also causing very big fragmentation very fast.

Does anyone know a solution to this problem?

After ~half hour I have this:

filefrag tmp_sys.img
    tmp_sys.img: 25154 extents found

and it's still saving... Completely unusable.

share|improve this question
    
Please, add some formatting to your question... –  pbm Apr 17 '12 at 17:42
    
i am new here, what exactly wrong with formatting ? –  sss123next Apr 18 '12 at 0:38
    
Look how your question is looking now... –  pbm Apr 18 '12 at 15:25
    
thx for hint, i will use better formatting ! –  sss123next Apr 18 '12 at 19:23
    
apparently this is not a bug -- bugs.launchpad.net/ubuntu/+source/qemu-kvm/+bug/741887 -- but a consequence of using default cache settings (cache=writethrough) –  sendmoreinfo Jan 27 '13 at 17:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.