Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed SELinux in Debian sid in order to use the sandbox that locks down apps to a restricted enviroment, but I can't get it to work. If I try to use the sandbox command in permissive mode without any options, like sandbox nano, I get the following error:

/usr/bin/sandbox: [Errno 22] Invalid argument

And if I try to run it with options for temporary home and tmp dirs, with or without the -X option, another error message pops up:

Could not set exec context to unconfined_u:unconfined_r:sandbox_x_t:s0:c236,c539.
Failed to remove directory /tmp/.sandbox-root-vfZJIt: No such file or directory

I have tried using the sandbox app in enforced mode, but it complains about missing type enforcement rules. I don't think that's the issue though. Does anyone know how to fix this?

share|improve this question
1  
It seems that the sandbox policy module isn't loaded. If I run semodule -l the sandbox module doesn't show up. Does anyone know how to load the sandbox policy module in Debian? – Magnus May 2 '12 at 3:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.