Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have 2 frames. I switch the buffer in first frame to buffer A. When I try to switch the buffer in the second frame to buffer A, Emacs brings the first frame forward. What I want is to open buffer A in both frames. Is there a setting that makes Emacs bring the other frame forward when buffer A is already opened in it?

share|improve this question
    
How exactly are you switching buffers? –  cjm Apr 13 '12 at 22:43
    
And what version of Emacs? I'm unable to reproduce the behavior you describe with Emacs 23.3. Try starting a new Emacs with emacs -Q to see if you've made some customization that's causing this. –  cjm Apr 13 '12 at 22:49

1 Answer 1

up vote 5 down vote accepted

That is a feature of “Ido”, which you seem to be using.

Just go to “Customize Emacs”, and in the group “Convenience / Ido”, change the settings “Ido Default Buffer Method” and “Ido Default File Method”, which surely are now set to “Raise frame if already shown”.

share|improve this answer
    
This is also the behavior of iswitchb-buffer. –  Juancho Apr 14 '12 at 2:46
    
Thanks. This was one of those mildly annoying things. –  hekevintran Apr 14 '12 at 3:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.