Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I would like to setup an old PC as a thinclient for our VMware View infrastructure. I need to disable the menu that pops up when I right-click on the desktop, along with some other things such as disabling the screen saver.

This is what I have done so far:

  • Disable LXDE screensaver

    Delete @xscreensaver –no-splash from /etc/xdg/lxsession/LXDE/autostart

  • Remove right click desktop menu options

    Right click on desktop and choose Desktop Preferences

    Select the advanced tab and check off Show menus provided by window managers when desktop is clicked

    Edit /etc/xdg/openbox/menu.xml and remove everything between <menu id=”root-menu” label=”Openbox 3”> and </menu>

  • Disable the LXPanel

    Edit /etc/xdg/lxsession/LXDE/autostart and comment out @lxpanel –profile LXDE.

All of this seems to work fine, but when I right-click the desktop I still see this:

Screenshot of the pop-up menu

How do I kill this?

share|improve this question

migrated from meta.unix.stackexchange.com Apr 13 '12 at 20:49

This question came from our discussion, support, and feature requests site for users of Linux, FreeBSD and other Un*x-like operating systems..

1  
It seems you have re-enabled pcmanfm desktop menu. Try to re-execute first part of step two. –  enzotib Apr 13 '12 at 21:13

2 Answers 2

See this post. You have to modify /etc/xdg/openbox/rc.xml and "smartly" remove all the tags matching a "ShowMenu" command. This will completely disable the OpenBox menus (all of them), but you can adapt it to your needs, as the file contents are pretty intuitive.

You can also modify a copy of this file under ~/.config/openbox/rc.xml to make the changes only for a given (set of) user(s), but being familiar with the thin client world, I think you want to remove it completely.

share|improve this answer
    
This never worked for me. Can you please update the right way tested in Ubuntu 13.10 64-bit but does not work. –  YumYumYum Apr 10 at 2:53

This question is very old, but you need to remove the line from /etc/xdg/lxsession/LXDE/autostart that is starting pcmanfm. The right-click menu you see there is not from openbox, but from the pcmanfm desktop window.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.